Windows 7

Tomd

Member
I just went back and read your post JRay. I assume you have a computer with Phoenix internet cruiser which I am not familiar with . I have read where they are supposed to be self healing which I have never needed. I will wait to see your reply and we can go from there to see if we can help you. I have been doing this type work for 20 years and you name it and I have just about seen it but I got lazy and not messed with computers very much in the last two years. I got back into golf carts which I like more plus I had a shop that needed me back lol
 

JRay

Cartaholic
Thanks Tom, my brother came over today,retired IBM guy. put a flash drive in it, wiped it out re installed 10. Everything seems good. this is a dell 6 gig machine I bought in 2012. Old for sure. This is something I wanted to try. I probably should buy a new one.
 

Tomd

Member
Thanks Tom, my brother came over today,retired IBM guy. put a flash drive in it, wiped it out re installed 10. Everything seems good. this is a dell 6 gig machine I bought in 2012. Old for sure. This is something I wanted to try. I probably should buy a new one.
Good deal, you wiped that stuff out. Check in device manager to make sure all your drivers are working. I have installed windows 10 on 10 year old computers with good success but sometimes it takes some tweaking to make everything work correct.
 

JRay

Cartaholic
I really like it. Kind of like coming out of the stone age. My lap top runs so much better. I bought a windows 10 book to learn all the ins and outs. Our gov. just locked us down for 3 weeks so I will have plenty of time to read it. :hattip:
 
Top