Pargo Golf Cart Speed Control

kthga

New Member
I am working on a 1975/76 Pargo golf cart with 8 solenoids. The sequence of the speed control disc does not seem to match the micro switch wiring. Does anyone have a Pargo that has found this problem?
Thanks kthga
 

HotRodCarts

Cartaholic
Is your Pargo running? If not can you give more details on what the problem is. Do you have the correct wiring diagram for it? Welcome to Cartaholics Golf Cart Forum. :hattip:
 

kthga

New Member
It is not running at this time. I am in the process of testing the micro switches and the solenoids. I do have the wiring diagram. The problem is when I turn the speed disc to increase the speed the #2 micro switch comes in before #1. I am trying to figure out why that would happen in that sequence. I have a service manual ordered and maybe it will help me understand this.
Thanks for your reply and any other info out there on a Pargo please let me know. Everything is appreciated.
KTHGA
 

kthga

New Member
Good morning. I did find the problem. It is the motor. The post on the S.2. terminal is broken inside the motor. I sent the stater to a repair shop and hope to get it back soon. This should fix my problem. Thanks Kenny
 

HotRodCarts

Cartaholic
Glad to hear you found the problem with the motor. Let us know hot it goes after you get the motor fixed and installed.
 

kthga

New Member
I have the Pargo up and running. I will post a picture of it as soon as I get it reassembled. It will be for sale if anyone is interested . Thanks Kenny
 
Top