New controller, cart still broke Help !!


i put in a new alltrax and pretty positive its wired up right, just like the old one was and as the instructions show.

got it all together drove about 100yds and went to turn around, and felt like it quit a little than kept going ,got turned around and quit for a couple seconds, than took off, kept foot on pedal, and went about 30yds than quit altogether . Came to stop so i held pedal down and cart jumped a couple times in forward and reverse but never took off again .
LED on controller blinks 4 times in green to show ITS throttle, after that it goes solid green. So it shows no problems. but cart don't move

not sure if related- but with old controller led battery guage said a little over half, put in new controller battery guage says full?? what?
put cart on charger last night , and meter went all the way to the right to charge up
havent been back there to test if it works now.

replaced old controller cause sometimes cart would go and sometimes all of the sudden quit found if i had wiggled a terminal on controller it would go again, for a day or 2 than after that you couldn't wiggle it enough to stay in a spot to get it to go. now i wonder if controller was bad at all.


I'm thinking your batteries either need a charge or you may have one or more bad batteries. See how it runs after a full charge. You might want to do a voltage test on the batteries if you're still having problems after charging.


i will hotrod thanks for the info, will keep posted,
going to 48v would be sweet not exactly the time for spending more but if i need batts though!

what charger would be a decent choice but not a fortune, for charging 48v.


went out sat after batteries charged up overnight and still nothing , soleniod clicks thats it cart dont move or nothing.
did not have time to check individual battery voltage yet.

what else could be wrong though, even with old controller everything worked fine then a day later it started to go intermintent then quit.


all right this is ridiculous i find out last night the day before, mom was driving cart around had no problems, but when i tried nothing.
batteries are those cheap sams club energizers ( came with cart)
last night got voltage and total volts were 38.7 , 4 batts were 6.3v and two were 6.4, but the total when tied was 38.7 .
put all wires back on took cover off of switch just to look, which was one screw, and tried the pedal for the heck of it and it ran. Drove it around constantly for about 4-5 minutes.and put it away dumb founded.
whats the deal with this thing!


New Member
There's probably nothing wrong with your batteries.
I agree with HRC, you may have a bad/loose connection, have you removed and cleaned the cables?

Next time it quits, if the solenoid is clicking but the cart doesn't run use a 6ga wire across the large terminals of the solenoid, if the cart runs replace the solenoid.
If it doesn't click check the microswitch on the throttle.

Side note on batteries, they are only as good as the maintenance they receive.
I've been using Sam's batteries since 1992 and have never had any problems with them.


hey thanks for the help guys, what special maintenance procedure do you do to your batteries?

anyone know what a middle of the road 48v battery charger cost, and the brand .

i'll keep you posted if still having problems.