My new, free toy.

whiteGIANT510

New Member
I just got this ezgo marathon on Craigslist for free. It was a burning man car and already had a predator 420cc. and since I got it a week ago I was going to replace the whole drive train but I was watching some videos and someone was driving the same cart, same engine and it died at a stop. I remembered the person I got it from said it was running and died at a stop and the thought it was the cvt. In the video they tore apart the cvt and it was stuck open. They cleaned it and off they went. I decided to pull the belt off mine and it fired right up. So I pulled the drive clutch and it is a comet 44c. I have no idea how to service this so I'm probably going to get a comet 40 unless someone can tell me how to get this thing apart. I'm sure glad I found the video. I was gunna junk a good 420 predator.
 

Attachments

  • 20210626_141447.jpg
    20210626_141447.jpg
    258.3 KB · Views: 2
  • 20210626_164212.jpg
    20210626_164212.jpg
    253.4 KB · Views: 2

whiteGIANT510

New Member
Thanks, I can now update that it is running and driving after cleaning the drive clutch but the driven isn't opening up im pretty sure the belt is too long. But whoever built this thing welded the mounting bolts to the plate so I cannot adjust it the way I needs it to be. Can someone tell me how much slack the belt should have. I know this must be the issue.
 

whiteGIANT510

New Member
It does. . It doesn't want to open up tho. I had to make the belt sit where it is on the driven so it would be free from the drive to start the engine. I probably need a new belt. I think it is too stiff. It was sitting outside like that for 2 years
 

whiteGIANT510

New Member
I just drove it up and down the street and the driven clutch is not opening up. Its only going 9mph. The drive is working great 👍 I don't have as wide a gap as guitarman but the belt is not touching even at idle. I'm trying to figure out what kind of driven clutch I have.
 

whiteGIANT510

New Member
I'm thinking the belt is too loose still. The spring on the driven is good and it moves smoothly by hand. But when I drive it the whole whopping 9mph its currently going, the belt rides the edge of the drive pulley but doesn't pull into the driven. I'd be frustrated if it wasn't free hahaha 😂 🤣 😅 🙃


20210728_200204.jpg
 

Attachments

  • 20210728_200144.jpg
    20210728_200144.jpg
    164.1 KB · Views: 1
  • 20210727_210407.jpg
    20210727_210407.jpg
    123.4 KB · Views: 1
  • 20210724_102716.jpg
    20210724_102716.jpg
    189.4 KB · Views: 1
  • 20210728_152554.jpg
    20210728_152554.jpg
    266 KB · Views: 1
Top