I ONLY HAVE FULL THROTTLE

fixture777

New Member
I have a 92 CC. I just got it running with a new coil and ignitor. It runs good but all I have is full throttle. I hit the pedal and as soon as it fires it goes to full throttle. I cannot run it slow.
Can someone help me??
Thanks!!!
 

EZ-GOnewild

New Member
Well you are ready for the races!
rotflmao.gif


Seriously, is there a throttle return spring missing or is the linkage kinked or stuck it the wide open position?
 

fixture777

New Member
I am not sure. This is my first CC. I really dont know what to look for. There is a spring on the butterfly. Do you know if there is a diagram to show what is should look like? I just got the thing going. I replaced the coil and the ignitor. The guy I got it from knew there was a spark problem. I fixed that to find out all I can do is go really fast.
Yes, it goes like crazy. Way too fast for my kids.
Any help you can give me would be very much appreciated.
wallbash.gif
 

HotRodCarts

Cartaholic
Look in the throat of the carburetor and make sure the butterfly is there. Club Cars are known for eating the butterfly. If the butterfly is still in the carb let us know and we'll go from there.
 

fixture777

New Member
It is still there. Either the governer cable is a little too long and binding or the return spring on the butterfly is too light. It seems to work if you work it with your hand. It is a little tight and binds. The cable looks brand new.
 

EZ-GOnewild

New Member
I'm probably not much help because I own EZ-GO's.

On the EZ-GO carbs there are two butterflies, one in the front that closes when you pull the choke and one behind it next to the intake manifold that opens from the gas pedal. Maybe your CC is similar and the rear one is stuck or missing. Just a shot...
 
Top