hot charging receptacle

wes64

New Member
98 EZGO , the receptacle where the charger plugs in is very hot. Happened to walk by yesterday and smelled it. New controller and selenoid installed abouot 1 year ago. All suggestions appreciated. Wes, the newbie
 

clubdean

New Member
Check all you conections and also meter each batt, to see if you have 1 or 2 that are below the voltage range of the others.
 

wes64

New Member
Thanks Caddie. I was outside with it and just came back inside ( gotta watch the football game). I took the plug apart and it was not dirty, but smelled of burned wires. All I accomplished there was to loose one of the screws that holds the handle together. The batteries are 6 years old this month, so that is probably most if not all the problem. The cart his used to check the mail and ride the dogs around and put ant killer on the many ant hills we have on 2 arces. The charger keeps going on for about 5 minutes and then cut off for a minute or so and the back on. It has really been good, but I do not want to buy new batteries and then it is somethin else. I do not have a volt meter. Will check the receptacle for dirt and loose wires, but again all thoughts appreciated. Wes
 

HotRodCarts

Cartaholic
Welcome to Cartaholics.

Clean the contacts on the charger plug and the charger receptacle. If it still gets hot you'll need to replace the contacts if all your other connections are clean and tight. Here's the part numbers.

EZGO TXT Charger connectors:

73051-G05 Radsok Female Pin - Charger Receptacle on cart
73051-G14 Radsok Male Pin - Charger Plug
 

wes64

New Member
Thanks guys. The receptacle end had a loose connection and was burned. I changed the male and female ends, and problem solved. Thanks. Wes
 
Top