EZGO Utility Cart Repair Questions

Soutthpaw

New Member
I bought a couple of these Utility Carts the I believe are EZGO at auction and there is absolutely no identification on them or on any of the parts. Does anyone know what brand or model they are? I've got some questions about repair. Thanks.
BF4CD9F9-E4D0-4293-A905-F2191B2A6FFA.jpeg1601C9A5-881D-4FCA-91A6-674901793D64.jpegEB4A0658-788B-4B29-A750-EDC8209077BC.jpeg6D2768C3-D758-4402-9E95-32DC5394AA4A.jpeg
 

Diode

Cartaholic - V.I.P.
This one looks to be a series cart and the spare tire has seen better days
 

Soutthpaw

New Member
Oh that was on my trailer I was using to tow the cart. Yeah I had to drive a few miles to the closest town and drop trailer then a 300 mile round trip today with new tire and rim
 

HotRodCarts

Cartaholic
Does anyone know what brand they are?
I'm not sure on manufacturer but if they're not EZGO's they could be Chinese knockoffs of a EZGO. What brand and model motors and controllers do the carts have?
Welcome to Cartaholics Golf Cart Forum. :hattip:
 

Soutthpaw

New Member
Found an EZGO part number on the inside of the controller cover. Also it was owned by Santa Monica college in CA so I doubt they buy knock offs. Maybe the warning notice also matches EZGO or another brand? Thanks. .
41AED465-F440-4C82-B849-8C154DBC5A8A.jpeg2AD8B3D1-C5B3-4968-9B4A-3C2E30CEE386.jpeg85BE18C7-76FE-4EFE-BCD7-37979AA60098.jpeg7C9A9774-F04A-4630-BBF7-4E08EAD7A4F5.jpeg
 

HotRodCarts

Cartaholic
If they're a EZGO carts there should be a plate in the passenger glove box or possibly a sticker under the seat with a manufactures code on them. If you can find that we can tell you what year they are.
 

Diode

Cartaholic - V.I.P.
The picture of the solenoid and all the large wires get a number off of that black box that should be your controller
 

Soutthpaw

New Member
Okay, I see where the tag is broken off in the passenger glove compartment.
The controller is EZ go #P255471 if they helps.
52E6E56C-E3DC-45F2-AC77-DB05053C58EC.jpegAC329634-C0CC-4061-B6F7-B310FD97A0AB.jpeg1A8FEF94-0B85-4F82-846E-25244E6DC870.jpeg
 

Soutthpaw

New Member
Found an image match on cartpros.com. Did Cushman and Jacobson use EZGO parts? Possibly they did the industrial commercial bodies? Is this
Like a Toyota/Lexus type of deal. This is an all steel body except for the hood.

F72D2D17-3CBE-48CC-B5C0-1B50D5F76C30.pngB1EB92A9-7E3F-4D6F-A466-A826988A6C03.png
 

HotRodCarts

Cartaholic
Yes Cushman used EZGO parts and your carts are probably Cushman's. Without the tag on the dash I can't tell you what year they are.
 

Soutthpaw

New Member
I put 3x 12 v batteries in it for testing. But I haven't found the manual for diagnostics for the controller I have with 4 large terminals on top. The one I have shows 3. I have voltage to and from the non existent key switch. Which is a toggle switch at the moment. The solenoid clicks when depressing the pedal but no power out. That's as far as I have gotten.
I'll probably be picking up my other 4 carts this weekend. 1 is identical to this one.

From left to right in pic. I have A2:B+:B-:M-
An explanation of what they are and how the system works would be helpful. Thanks
image.jpg
 

HotRodCarts

Cartaholic
If the solenoid is clicking and there's no power at the large posts the solenoid is probably bad. Try jumping the 2 large posts on the solenoid with a 6 gauge or larger cable and then see if the cart will move. The A2 terminal on the controller is for plug braking. The wiring diagram here on the forum shows how to wire the cart with or without using the A2 terminal. Also it looks like those cable ends aren't crimped and soldered on the cable very well and will cause problems at some point.
 

Soutthpaw

New Member
ok I looked closer at the service manual I have. It does show 4 top terminals they Just didn't label A2. Okay its for braking Is it regenerative braking?
I should probably move or start a repair thread in the EZGo section now I know what it is. I have power out of the main terminals just not out of M- when throttle is depressed, im just in the house reading the manual and realized I read the diagnostic proceedure wrong also. I'm gonna read the whole section and then tackle it again
 

HotRodCarts

Cartaholic
The plug breaking that uses A2 on the controller never really worked as far as I know and EZGO stopped using it. If you'd like to start a new thread that's fine, or I can move this one if you want it in the EZGO repair section. :hattip:
 

Soutthpaw

New Member
I'm at this point where it says repair red harness wire as I have open circuit with no throttle and battery voltage on red wire with pedal depressed step #16. What does this mean. I done see any reference to address this repair. Page F-7 in this manual.https://www.cartpros.com/mm5/manuals/E-Z-GO/Utility-Vehicles/27.pdf
3C3D0535-94C3-487A-AFC2-7FF484BC61BB.jpeg
 

Soutthpaw

New Member
The plug breaking that uses A2 on the controller never really worked as far as I know and EZGO stopped using it. If you'd like to start a new thread that's fine, or I can move this one if you want it in the EZGO repair section. :hattip:
If you can move it and change title to something like EZ go utility cart repair would be great.
 
Top