EZGO TXT With DCS Motor Burnt Wire to Controller

Woodchopper

New Member
1996 EZGO with DCS motor had a burnt wire to controller. Repaired it. At first car would click when shifted to forward but nothing when shifted to reverse. Next day now and it does nothing. No solenoid clicks, nothing when shifting to forward or reverse. It has a DCS motor. Need a tech manuel or text me some advice.
 

HotRodCarts

Cartaholic
Which wire going to the controller was burnt? The EZGO DCS controllers are very easy to blow if anything shorts while the run tow switch is in the run position. There's a EZGO DCS troubleshooting guide in the resource section of the forum. Let us know which wire burnt. Welcome to Cartaholics Golf Cart Forum. :hattip:
 

Woodchopper

New Member
As you face the controller, it’s the top right wire. Large black wire. When this wire burnt into, it did so right at the connector. After crimping new end on, it clicked in forward but nothing in reverse . Now it does nothing.
 

Woodchopper

New Member
Since my last post, I've replaced controller with new unit. Cart now goes forward in forward and also goes forward in reverse. Batteries are charged and shifter seems to be OK.
 

HotRodCarts

Cartaholic
Have you double checked all of the wiring? Sounds like something isn't wired correctly. Does the reverse alarm come on when you put in in reverse?
 

gornoman

Well-Known Member
Since my last post, I've replaced controller with new unit. Cart now goes forward in forward and also goes forward in reverse. Batteries are charged and shifter seems to be OK.
Check the electrical operation of both microswitches behind the F/R lever. Make sure both switches are making/breaking contact.
 
Top