EZGO TXT Makes a Constant Buzzing Sound

Cart 259

New Member
New to the forum. New to golf carts. I have a 2004 EZGO TXT with the Precesion Drive System. I installed all new batteries and the cart runs great. Only problem is the golf cart makes a constant buzzing sound. It sounds like the reverse/warning buzzer just not as loud. As long as batteries are connected it buzzes. Any idea what this might be ? Thanks in advance for your help.
 

HotRodCarts

Cartaholic
Are you sure it's not the reverse alarm? The buzzer can be quieter if less voltage is being sent to it. If not you're going to need to pinpoint the area the noise is coming from. It could possibly be the controller making the noise.
 

Cart 259

New Member
I think it is the reverse buzzer just real quiet. It buzzes constantly when batteries are connected. Is this normal for this cart or do I maybe have a problem?
 

HotRodCarts

Cartaholic
Like Diode said there's a problem. The reverse alarm shouldn't make any noise unless the golf cart is in reverse. Did it do this with the old batteries?
 

Cart 259

New Member
According to the previous owner it did. It’s really faint sound. Unless it’s quiet you can’t hear it. If I unhook the batteries it stops immediately. Could it possibly be the relay ? I haven’t opened up the controller yet to check on anything.
 

HotRodCarts

Cartaholic
Put your ear by the plastic cover on the controller and see if that's where the noise is coming from. There's 4 bolts that hold the cover on if you need to remove it to be sure. If it's the reverse alarm the noise should be coming from the dash by the key switch. I have heard controller make a high pitched whine usually when their ready to go bad.
 

Diode

Cartaholic - V.I.P.
I would pull all of the controller contacts out and clean them with some vinegar and a toothbrush then spray them down with contact cleaner
 

Cart 259

New Member
Sound is definitely coming from behind the dash. Key switch off. Key in my pocket. Forward/reverse switch in “neutral “. Still buzzing.
 

Cart 259

New Member
I did check /clean up the wiring inside the PDS controller. I also found the hot wire to brake lights was shorted to frame and fixed that problem. Buzzing noise seems to be a little weaker sounding now. I checked and I am still showing voltage to frame so sometime this week I plan to check head light wiring as well.
 

viper05

New Member
did you find the problem, i just got a cart that is doing the same thing. constant buzz when batteries are connected, goes away when disconnected and louder in reverse
 
Top