EZGO 36v PDS Troubleshooting Q’s

SgtBryan86

New Member
Hello all. I’ve got issues on troubleshooting this PDS cart. Don’t know the exact year, data plate has been removed. Tried running diagnostic mode, and all I get is the confirmation beep. I have a new motor, key switch, and F/R switch installed. Batteries are less than a year old Rockets.
Here’s where I run into problems in the troubleshooting area:

CHECKING CONTROLLER INPUT

Connect (-) probe to B- terminal. Connect (+) probe to B+ terminal.

The reading should indicate approx. 0 volts with the resistor REMOVED and the pedal not pressed in the last 15-30 minutes.

~ I have pack voltage at those terminals.~

CHECKING CONTROLLER OUTPUT

Slowly depress accelerator pedal until the solenoid engages. Watch the voltmeter.

The reading should show the battery pack voltage. Now slowly depress the pedal and watch the reading, it should go down to nearly 0 volts.

~Depressing pedal, I have pack power when solenoid clicks, then only drops to around 33 volts with pedal to the floor before it goes right back up to pack power.~

I’d appreciate any advice anyone can give.
 

Golf Cart Wizard

Cartaholic - V.I.P.
Measure between A and B-, should have 36v when the solenoid clicks and go to 0 at full pedal. If you have 0 always the motor has a bad armature connection or is bad. If it is changing but the golf cart isn’t moving check the field wires to the motor.
 

SgtBryan86

New Member
It drops about a volt with solenoid click, and going to floor, the voltage drops to about 25 and then goes back up. I’ve replaced the white F1 cable. I’ll change out the other, then maybe see about the other two main ones. What I can say is all of my connections are tight.
 

SgtBryan86

New Member
Back to the drawing board…
Changed the black and white cables that run to the F posts, plus the ones in the charge port. Checked the A post cables, they’re tight, no signs of damage. The only two things I haven’t replaced are the controller and the solenoid.
The only other issue I can think of it being is the controller. It was probably from trying a series motor on it…
 
Top