Dead Yamaha G16 Golf Cart

JBeastquogue

New Member
I have a Yamaha G16E golf cart with a new issue.
I take it off the charger back it out of the garage put it in forward goes for a 1:2 second then dies. I put it back on the charger and it seems all good, but as soon as I try the same situation repeats itself. Is there something mechanical I should check?
TIA
Joe
 

HotRodCarts

Cartaholic
I'd start with checking all the connections from the forward and reverse switch. It could also be a bad solenoid.
 

JBeastquogue

New Member
I appreciate the advice HOT ROD---
I just changed out all battery connections with new hardware. I cleaned all posts and battery cable fittings.
It's on the charger now...
Where is the solenoid i'll get one and change that out too.
Anything else i should swap out?
I need this cart working for my wife in a hurry, she has MS and cant get around that well.
I don't want to keep putting on band aids.
Thanks in advance!!!
Joe
 

HotRodCarts

Cartaholic
Before buying a solenoid put a multi meter on the battery pack and check the voltage and post those results. When the golf cart stops moving does the solenoid still click when you press the throttle?
 

JBeastquogue

New Member
Ok i charged the pack overnight, it Runs but only at 5-6 mph.
What i am thinking, it WAS :censored:ty connections and now weak batteries.
I will put a Multi meter on the pack and post the results.
Thanks again!!
 

JBeastquogue

New Member
After testing the pack-39v overall between 6.2-6.6v ea battery.
The sides of the batteries were bowed out.
I have 6 new Interstate batteries being delivered tomorrow.
I guess we will see what happens to top speed
Taking this opportunity to clean and undercoat the cart.
Thanks!
 

JBeastquogue

New Member
Running great with the new batteries and all connections removed cleaned and replaced.
Double the speed!!
I thank you for your help with this issue. keep up the good work!!!
Joe
 
Top