Club Car Power Drive 2 Charger Issue - Making sure I am on the right track

JaxCart

New Member
I have a Club Car Power Drive 2 battery charger issue. It "clicks" when plugged in but the needle for the amperes doesn't move.

I've disconnected the negative battery pack terminal and am going to let it sit for an hour then try to charge again.

If still nothing, I probably have a problem with the O.B.C. ?

Any help appreciated.
 

Diode

Cartaholic - V.I.P.
Maybe post the results after resetting the OBC is turning the charger on so you’re either not getting power on the 117 or the scr is not allowing it to charge
I’ll give you some other test to run after resetting
 

JaxCart

New Member
Quick update - after leaving the battery disconnected for an hour and re connecting, still the same thing. When plugged in there is a "click" on the charger - which makes me think that it is getting D.C. power from the cart. I've checked the breaker and GFI outlet its plugged in to and its good.
Am thinking the charger is not getting A.C. power somehow.
 

Diode

Cartaholic - V.I.P.
On the charge receptacle run a jumper from the black wire to the battery pack negative and try charging
 

JaxCart

New Member
Sorry took me a while to get around to trying. Did your recommendation and same result - charger kicked on but didn't move amperes any.
 

Diode

Cartaholic - V.I.P.
Either you’re not getting 115 V at the receptacle the relay, diodes are bad or the transformer is bad
 

Diode

Cartaholic - V.I.P.
Make sure the charge receptacle is hooked to the batteries and not going somewhere else
 
Top