Club Car Has No Spark

fts1966

New Member
OK short story, golf cart has been sitting 8 years. We got it for cleaning up a yard at the lake they said the engine locked up. We messed with it yes engine locked up. Oh its a 1995 Club Car DS gas golf cart. We pulled the engine tore it down found the issue bought parts put it back together. New gas and cleaned everything up put it in service mode it started after about a min once fuel got to the carburetor. I did not fill the oil up all the way I wanted to make sure the oil light worked it was on for low oil. It ran great and really happy, then I added oil and brought it up to full. Started up oil light went out and it died and now have no spark. I did the tests with coil got good readings pulled the rev limiter and the ignitor. I replaced and still no spark checked ignition switch its in good shape.
Why would it run great low on oil then not with correct about of oil? And yes it ran great we did service mode for over 5 minutes nice and quiet and smooth and started over and over about 6 times.
 

Nubs

Cartaholic
I would unhook the wire from the oil level sensor and see if ya get spark, should have nothing to do with it but its odd that is the only thing that changed:dazed:

Welcome to the Forum.
 

fts1966

New Member
okay after getting to know the wiring and how things work we had a bad micro switch. We replaced all 4 of them then the ignition switch was intermittent replaced it as well and now we are running and driving.

thank you
 

fts1966

New Member
well its not running again adjusted the linkage and it ran great in service mode then died and now we have nothing and after 2 hours and the body off again and still not able to get spark
 
Top