Club Car Electric Golf Cart Stopped Running

kafecup

New Member
Hi. I am new to this forum and need help. My 1993 36 volt electric Club Car golf cart stopped running. Every thing was fine. The next time I tried it, it did nothing. I put in a new solenoid and a new OBC. Still No Go. I've reset the OBC. Still nothing. No clicks. No nothing. Batteries are fully charged and good. Is there way to bypass the OBC to check the motor. I'm at a loss as to what to do next.
 

HotRodCarts

Cartaholic
Welcome to the forum...

Are you sure the cart is a 93? If it is you don't have a OBC. Try testing the key switch with a meter to make sure it's working. Check all cable connections...
 

kafecup

New Member
Oooooops. Rookie mistake. Sorry. Its a speed control box. I'll get a meter this morning and start testing my circuits. I'll let you know. Thanks.
 

kafecup

New Member
Hi. There is current across the ignition switch. Each battery tests at 6.7v. There is current thru the solenoid. There is a black V shaped box , speed switch, that clicks when I put down the accelerator and then stops. All battery connections are Ok. The the forward/reverse terminals are clean.
 

HotRodCarts

Cartaholic
Next thing to check is the motor....

Series Motor Test:

Disconnect the main positive and negative cables from the battery pack. Jack up the the rear of the golf cart and place on jack stands. Remove all wires from the motor. Put a jumper wire from an "A" terminal to an "S" terminal. Hook a 12 volt battery or 12 volt battery charger with 15+ amp range to the other "A" and "S" terminals that aren't jumped with the jumper.
 

kafecup

New Member
OK. I'll try that tomorrow. Rookie/newbie question - I am confuse tho. What is an "A" Terminal and an "S" Terminal? Newbie has a brain cramp for this.. . From where to where. Sorry about this.
 

kafecup

New Member
Thanks for eveything Hot Rod Carts. You have been very helpful through all this. I'll let you know how things turn out.

Thanks Again
 
Top