Club Car Battery Charging

Flat blade

New Member
I have a 2007 Club Car Precedent. The Batteries 4 x 12 volts were completely dead and the battery charger did not operate correctly, so I charged the Batteries indivualaly. The problem I have now is after charging the Battery gauge on Dash shows only two bars. When I drove it out the driveway it has very little power or speed. I'm not sure what I need to check to proceed. Any help . Thanks Flatblade.
 

Nubs

Cartaholic
What is the voltage of the pack after charging and letting them rest for an hour, needs to be checked with a digital volt meter.

Welcome to the Forum:hattip:
 

Diode

Cartaholic - V.I.P.
The batteries need to be just over 20 V for the stock charger to kick on measure your lowest battery voltage put the charger on that battery wait about a half an hour and plug your stock charger in , and if it kicks on and you can unplug the other charger
 

Flat blade

New Member
I checked all four batteries this afternoon and all were 12.43 to 12.47 volts. I have just received today my new battery charger for Club Car and it did exactly what it was suppose to do. I checked the gauge on dash and after thirty minutes up to full capacity. So I guess my problem is fixed but will not know for sure till tomorrow. Thanks Guys for helping. If y’all need any advice on wreck vehicles I can help.
 

HotRodCarts

Cartaholic
Glad to hear you got the golf cart running and charging like it should. Thanks for the follow up. Welcome to the forum. :hattip:
 
Top