97 regen won't charge won't run


New Member
I have a 97 CC Centennial Regen. It had been in storage for several years before I got it. I put good batteries in it and when I tried it it wouldn't go. The solenoid clicks and the backup horn sounds but nothing except a sort of whinning noise from the back end.

When I plugged in the charger it clicks but doesn't start to charge. My charger does work on other carts.

I tried to reset the OBC and unlike the directions I received, the backup horn didn't stop after 30 seconds. I also don't appear to have a tow switch or a fuse receptacle, just an inline fuse in a yellow waterproof case,

Would a bad solenoid cause the charger from charging as well as making the cart not move? What would be the next trouble shooting steps. I put the cart in reverse and jumped both sides of the solenoid but still nothing happened


New Member
Really sounds like you have some wires crossed or grounding. 1st I would check to make sure batteries are connected properly, you can find a wiring diagram online to make sure you have it correctly. After you have done that, take a meter and check battery voltage, if that is ok, check wires thru out system to make sure no rat chews or grounded wires. If thats ok, meter wires to computer board, controller, solenoid and motor to make sure you are getting voltage thru each system. once you see no current thru one of the units that is pretty much where your trouble is. But if you just want to change out the solenoid. I have never had luck trying to jump a solenoid..