2004 Jacobsen Hauler 1200 Cranks But Doesn't Start

Bustinbeards

New Member
New to carts and new to the site. I bought a 2004 Jacobsen Hauler 1200 which I understand is a rebranded EZGO Workhorse. It is in pretty good shape has been sitting under a tree for a year or so after the owner passing away. It cleaned up well. It has a robin EH352cc engine that cranks over but doesn't start. I was told the oil injection pump had been bypassed and mix the gas. The fellas son’s said 50:1 but that seems very rich to me. I don’t know anything about carts yet, so here I am. I’ll add some pics please feel feed to add any advice, thanks!


 

Bustinbeards

New Member
Drained the gas this morning and the battery has 100% charge. Mixed up some new gas at 80:1 because it has sat for a while. It cranks but doesn’t fire. The carb is dumping excess gas when the choke is pulled, so I figure next step is to pull the carb and clean it up. Or should I just order a new one?
 

Zman

Cartaholic
You need to drain it again and clean out carb. The Robin engine is a 4 stroke and does not need a pre mix oil. Just GAS.
 

Nubs

Cartaholic - V.I.P.
Do whatever you can to reuse the factory carb, the aftermarket stuff are nuttin' but trouble. Need to get straight non ethanol mixed fuel if at all possible, the oil mixed fuel will be a problem also:twocents:

That will be a nice machine once ya get her running.
 

Bustinbeards

New Member
Thanks for the info on the mix gas. Luckily I had only mixed up 1/2 gal of gas just to get it started. I got it all drained out of the tank and replaced with 89 octane non-ethanol gas. I took the carburetor off and cleaned it up it got everything back together. The fuel pump is working great. The battery is a 2018 so I don’t think this cart has been sitting too long. She tried to fire up so I pulled some choke and it cranked right up. I was also told it was weak and lost its pull up hill the seller thought it needed a clutch or a belt. I took a tape to the belt and it looks to be good at 1 1/8”. I’ll add a pic if it. It seems to run at least 15+ on flat ground. It pulls hills without feeling like it’s slipping but I’m not sure really how it's supposed to pull hills at speed. So far I have 525$ in it. What should I do next?

 

Bustinbeards

New Member
So I have been tinkering with this little cart and it is coming along very nicely. The original battery in it is holding a charge and appears to be a 2018. The top was very wobbly because the seat bracket was broken. I was able to get the broken seat brackets off by pulling the rounded bracket bolts through the frame where the holes had been wallowed out. After getting the lock nuts off with vice grips, I mounted the brackets back up with several large stainless fender Washers and new lock nuts. That 8$ fixed the top and seat issues. I degreased the engine compartment and noticed it appears that it has been modified with a spring on top of the rear ended. Anyone have any suggestions What it is?
seat brackets
Engine compartment
Is this modified?
 
Top