2000 Club Car DS Electric 36V - Rattling Noise from Rear End???

jt283283

New Member
Well, stethoscope I believe is pointing to motor. I can hear it from both motor and axle. Motor seems to be louder. Centering guide a fairly simple install?
 

jt283283

New Member
Anyone know where I can purchase the club car AM10039 centering kit in the event that the centering guide doesn’t fit my 2000 ge motor? I can’t seem to find anyone or any company online stocking these kits to order.
 

jt283283

New Member
I posted a link to an aftermarket part earlier in this thread
I did order that centering guide, thanks for that link. Supposed to arrive sometime next week. I went down a rabbit hole last night reading about the installation and saw a few mentions of the AM10039 centering kit that HotRod had originally recommended. This kit includes a few washers, spring, and centering guide. Revolution golf cars has this statement on the motor guide ring:

"101789101 - MOTOR GUIDE RING FITS LATE 80s TO LATE 90s CLUB CAR VEHICLES WITH NYLON GUIDE RINGS IN THE OUTPUT SHAFT OF THE MOTOR. FOR SOLID SHAFT MOTORS, USE AM10039 MOTOR CENTERING KIT INSTEAD"

Was just curious if I happen to have a solid shaft motor (Which I may not, still have to verify) probably worth ordering the AM100039 kit in parallel so that I will have the correct parts once I remove the motor for the install. Probably overthinking it per usual, but I couldn't find anywhere online to buy this AM100039 kit.
 

jt283283

New Member
Did some calling around, apparently club car discon took nude the part and no local dealers can get their hands on it anymore. Pretty sure my cart requires this as opposed to the centering guide based on the serial number. Crazy.
 

jt283283

New Member
Did some calling around, apparently club car discon took nude the part and no local dealers can get their hands on it anymore. Pretty sure my cart requires this as opposed to the centering guide based on the serial number. Crazy.
Discontinued* not discon took nude
 

jt283283

New Member
Well everyone, finally sacked up and pulled the motor. Well attempted to and the armature pulled out of the case which led to me to discover the issue causing the metallic rattle. God damn both bearing retainer screws backed out at some point and dropped off the case. Found one underneath where I park the cart. Must’ve slipped out when I initially jacked it up to address the squealing driver side brakes. Odd shaped bearing retainer was just bouncing off the armature shaft causing the intermittent rattle. Found another similar screw in the garage, buttoned it back up and just took it for a mile long 4am cruise, zero noise. Did not end up needing the bumper I ordered or the centering piece, but thank you all for the suggestions that in one way or another ultimately led to resolution. Much appreciated.
 

Attachments

  • IMG_9914.png
    IMG_9914.png
    155.5 KB · Views: 5
  • IMG_9915.png
    IMG_9915.png
    717.3 KB · Views: 5
Top