1995 EZGO DCS Troubleshooting Won't Run


New Member
I have a 95 DCS model that won't run: tried following the EZGO troubleshooting guide and have some strange readings. I have exactly the same voltage at both of the large solenoid posts (Solenoid clicks when throttle pressed). The EZGO book says I should be up to 3V less on the controller side of the solenoid, but I'm not. Also I'm supposed to be in the 14v range for the inductive sensor with all wiring hooked up and I'm not. I removed the sensor wiring and the voltage went back up so I replaced the sensor but still the same problem. I jacked the cart up and ran the battery right to the motor and it turns so it's not a motor fault. All control voltage is ok, ie; reed switch, forward/reverse, key switch etc. I'm going to change the solenoid but at this point I'm fearing it's the controller.....any ideas?


New Member
Make sure all your connections are good. My DCS quit working the other day. I had to troubleshoot it for almost a week and could not figure it out. Turned out to be the forward/reverse cables on the controller were not getting a good connection. Even changing the ends on the cable didnt help. I had to crimp the ends directly on the post.